git subrepo clone --branch=master https://aur.archlinux.org/python-casttube
subrepo: subdir: "python-casttube" merged: "c04a50c" upstream: origin: "https://aur.archlinux.org/python-casttube" branch: "master" commit: "c04a50c" git-subrepo: version: "0.4.3" origin: "???" commit: "???"
This commit is contained in:
parent
cbafd65c02
commit
b7f54b5eb5
17
python-casttube/.SRCINFO
Normal file
17
python-casttube/.SRCINFO
Normal file
@ -0,0 +1,17 @@
|
||||
pkgbase = python-casttube
|
||||
pkgdesc = YouTube chromecast api
|
||||
pkgver = 0.2.1
|
||||
pkgrel = 2
|
||||
url = http://github.com/ur1katz/casttube
|
||||
arch = any
|
||||
license = MIT
|
||||
makedepends = python-setuptools
|
||||
depends = python
|
||||
depends = python-requests
|
||||
source = https://github.com/ur1katz/casttube/archive/0.2.1.tar.gz
|
||||
source = license.patch
|
||||
sha256sums = 351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33
|
||||
sha256sums = cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556
|
||||
|
||||
pkgname = python-casttube
|
||||
|
12
python-casttube/.gitrepo
Normal file
12
python-casttube/.gitrepo
Normal file
@ -0,0 +1,12 @@
|
||||
; DO NOT EDIT (unless you know what you are doing)
|
||||
;
|
||||
; This subdirectory is a git "subrepo", and this file is maintained by the
|
||||
; git-subrepo command. See https://github.com/git-commands/git-subrepo#readme
|
||||
;
|
||||
[subrepo]
|
||||
remote = https://aur.archlinux.org/python-casttube
|
||||
branch = master
|
||||
commit = c04a50ce8997e235540bd048ef7b573ab7c9cedd
|
||||
parent = cbafd65c02043dbff1f2d73a4caaa1fcd181d740
|
||||
method = merge
|
||||
cmdver = 0.4.3
|
32
python-casttube/PKGBUILD
Normal file
32
python-casttube/PKGBUILD
Normal file
@ -0,0 +1,32 @@
|
||||
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
|
||||
|
||||
_name=casttube
|
||||
pkgname="python-$_name"
|
||||
pkgver=0.2.1
|
||||
pkgrel=2
|
||||
pkgdesc='YouTube chromecast api'
|
||||
url='http://github.com/ur1katz/casttube'
|
||||
depends=('python' 'python-requests')
|
||||
makedepends=('python-setuptools')
|
||||
license=('MIT')
|
||||
arch=('any')
|
||||
source=("https://github.com/ur1katz/casttube/archive/${pkgver}.tar.gz"
|
||||
license.patch)
|
||||
sha256sums=('351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33'
|
||||
'cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
patch --forward --strip=1 --input="${srcdir}/license.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
python setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
|
||||
}
|
12
python-casttube/license.patch
Normal file
12
python-casttube/license.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index feb39f2..14fb206 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -12,7 +12,6 @@ setup(name='casttube',
|
||||
author='Uri Katz',
|
||||
author_email='4urikatz@gmail.com',
|
||||
license='MIT',
|
||||
- data_files = [("", ["LICENSE"])],
|
||||
packages=['casttube'],
|
||||
zip_safe=False,
|
||||
keywords = ['youtube', 'chromecast', 'youtube-api'],
|
Loading…
Reference in New Issue
Block a user