git subrepo clone --branch=master https://aur.archlinux.org/zinnia.git
subrepo: subdir: "zinnia" merged: "215fc9b" upstream: origin: "https://aur.archlinux.org/zinnia.git" branch: "master" commit: "215fc9b" git-subrepo: version: "0.4.3" origin: "???" commit: "???"
This commit is contained in:
parent
dc84a68b75
commit
8df002a49c
12
zinnia/.SRCINFO
Normal file
12
zinnia/.SRCINFO
Normal file
@ -0,0 +1,12 @@
|
||||
pkgbase = zinnia
|
||||
pkgdesc = Simple, customizable and portable online hand recognition system based on Support Vector Machines
|
||||
pkgver = 0.07
|
||||
pkgrel = 1
|
||||
url = https://github.com/silverhikari/zinnia
|
||||
arch = x86_64
|
||||
license = BSD
|
||||
depends = gcc-libs
|
||||
source = https://github.com/silverhikari/zinnia/releases/download/0.07/zinnia-0.07.tar.gz
|
||||
sha256sums = a1f537b67ac37319740d747a5eb101f0a327b0c483aecf8030c32eb3a133b07f
|
||||
|
||||
pkgname = zinnia
|
12
zinnia/.gitrepo
Normal file
12
zinnia/.gitrepo
Normal file
@ -0,0 +1,12 @@
|
||||
; DO NOT EDIT (unless you know what you are doing)
|
||||
;
|
||||
; This subdirectory is a git "subrepo", and this file is maintained by the
|
||||
; git-subrepo command. See https://github.com/git-commands/git-subrepo#readme
|
||||
;
|
||||
[subrepo]
|
||||
remote = https://aur.archlinux.org/zinnia.git
|
||||
branch = master
|
||||
commit = 215fc9b564f15bb4687a8a00fcafa2cfa3161fc5
|
||||
parent = dc84a68b754757fdd56dd7a2225ee1434fa845d4
|
||||
method = merge
|
||||
cmdver = 0.4.3
|
25
zinnia/PKGBUILD
Normal file
25
zinnia/PKGBUILD
Normal file
@ -0,0 +1,25 @@
|
||||
# Maintainer : silverhikari
|
||||
# Contributor: Felix Yan <felixonmars@archlinux.org>
|
||||
# Contributor: Humbert Julien <julroy67 [AT] gmail.com>
|
||||
|
||||
pkgname=zinnia
|
||||
pkgver=0.07
|
||||
pkgrel=1
|
||||
pkgdesc="Simple, customizable and portable online hand recognition system based on Support Vector Machines"
|
||||
arch=('x86_64')
|
||||
url="https://github.com/silverhikari/zinnia"
|
||||
license=('BSD')
|
||||
depends=('gcc-libs')
|
||||
source=("https://github.com/silverhikari/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz")
|
||||
sha256sums=('a1f537b67ac37319740d747a5eb101f0a327b0c483aecf8030c32eb3a133b07f')
|
||||
build() {
|
||||
cd $pkgname-$pkgver
|
||||
./configure --prefix=/usr
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd $pkgname-$pkgver
|
||||
make DESTDIR="$pkgdir" install
|
||||
install -Dm644 "$srcdir/$pkgname-$pkgver/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
21
zinnia/zinnia-gcc6.patch
Normal file
21
zinnia/zinnia-gcc6.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- a/trainer.cpp
|
||||
+++ b/trainer.cpp
|
||||
@@ -93,7 +93,7 @@ class TrainerImpl: public Trainer {
|
||||
|
||||
public:
|
||||
bool add(const Character &character) {
|
||||
- const std::string y = character.value();
|
||||
+ std::string y = character.value();
|
||||
CHECK_FALSE(!y.empty()) << "input character is empty";
|
||||
Features features;
|
||||
CHECK_FALSE(features.read(character)) << "cannot read character: " << y;
|
||||
@@ -103,7 +103,7 @@ class TrainerImpl: public Trainer {
|
||||
if (!fn) {
|
||||
return false;
|
||||
}
|
||||
- x_.push_back(std::make_pair<std::string, FeatureNode *>(y, fn));
|
||||
+ x_.push_back(std::make_pair(y, fn));
|
||||
return true;
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user