git subrepo clone --branch=master https://aur.archlinux.org/python-pychromecast6
subrepo: subdir: "python-pychromecast6" merged: "c167052" upstream: origin: "https://aur.archlinux.org/python-pychromecast6" branch: "master" commit: "c167052" git-subrepo: version: "0.4.3" origin: "???" commit: "???"
This commit is contained in:
parent
b7f54b5eb5
commit
77474f758f
24
python-pychromecast6/.SRCINFO
Normal file
24
python-pychromecast6/.SRCINFO
Normal file
@ -0,0 +1,24 @@
|
||||
pkgbase = python-pychromecast6
|
||||
pkgdesc = Library for Python 3 to communicate with the Google Chromecast
|
||||
pkgver = 6.0.1
|
||||
pkgrel = 5
|
||||
url = https://github.com/balloob/pychromecast
|
||||
arch = any
|
||||
license = MIT
|
||||
makedepends = python-setuptools
|
||||
depends = python
|
||||
depends = python-protobuf
|
||||
depends = python-requests
|
||||
depends = python-zeroconf
|
||||
depends = python-six
|
||||
depends = python-setuptools
|
||||
depends = python-casttube
|
||||
provides = python-pychromecast=6.0.1
|
||||
conflicts = python-pychromecast
|
||||
source = python-pychromecast6-6.0.1.tar.gz::https://github.com/balloob/pychromecast/archive/6.0.1.tar.gz
|
||||
source = is_alive.patch
|
||||
sha512sums = f4b881a559e89d7eb81487ce44c13ac707831a731d348418a78d4786a559abb3c6e98c6b1aa762ad14e5c4461de9a7254ce68c7543bb80e30ce4c3af08d7b24e
|
||||
sha512sums = bfe81d4de9011084046a487ba76cb6bc2d70fd7e7eeeaf9de45d0454353bcfd974c1df494ebb286d0438d4a6534101a83da8d95d2333af4b5d45b45f56f9aa3a
|
||||
|
||||
pkgname = python-pychromecast6
|
||||
|
5
python-pychromecast6/.gitignore
vendored
Normal file
5
python-pychromecast6/.gitignore
vendored
Normal file
@ -0,0 +1,5 @@
|
||||
*
|
||||
!.gitignore
|
||||
!.SRCINFO
|
||||
!PKGBUILD
|
||||
!is_alive.patch
|
12
python-pychromecast6/.gitrepo
Normal file
12
python-pychromecast6/.gitrepo
Normal file
@ -0,0 +1,12 @@
|
||||
; DO NOT EDIT (unless you know what you are doing)
|
||||
;
|
||||
; This subdirectory is a git "subrepo", and this file is maintained by the
|
||||
; git-subrepo command. See https://github.com/git-commands/git-subrepo#readme
|
||||
;
|
||||
[subrepo]
|
||||
remote = https://aur.archlinux.org/python-pychromecast6
|
||||
branch = master
|
||||
commit = c167052a4d8ea0eee827901bece9330e7d8d4e2a
|
||||
parent = b7f54b5eb50e2be39977b9367ed95735e64dd833
|
||||
method = merge
|
||||
cmdver = 0.4.3
|
35
python-pychromecast6/PKGBUILD
Normal file
35
python-pychromecast6/PKGBUILD
Normal file
@ -0,0 +1,35 @@
|
||||
|
||||
# Maintainer: Michael Riegert <michael at eowyn net>
|
||||
# Contributor: Felix Golatofski <contact@xdfr.de>
|
||||
# Contributor: Sibren Vasse <arch@sibrenvasse.nl>
|
||||
# Contributor: Daniel M. Capella <polyzen@archlinux.info>
|
||||
# Contributor: Morten Linderud <morten@linderud.pw>
|
||||
|
||||
pkgname=python-pychromecast6
|
||||
_name=pychromecast
|
||||
pkgver=6.0.1
|
||||
pkgrel=5
|
||||
pkgdesc='Library for Python 3 to communicate with the Google Chromecast'
|
||||
arch=('any')
|
||||
url=https://github.com/balloob/pychromecast
|
||||
license=('MIT')
|
||||
depends=('python' 'python-protobuf' 'python-requests' 'python-zeroconf' 'python-six' 'python-setuptools' 'python-casttube')
|
||||
makedepends=('python-setuptools')
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/balloob/pychromecast/archive/$pkgver.tar.gz"
|
||||
"is_alive.patch")
|
||||
sha512sums=('f4b881a559e89d7eb81487ce44c13ac707831a731d348418a78d4786a559abb3c6e98c6b1aa762ad14e5c4461de9a7254ce68c7543bb80e30ce4c3af08d7b24e'
|
||||
'bfe81d4de9011084046a487ba76cb6bc2d70fd7e7eeeaf9de45d0454353bcfd974c1df494ebb286d0438d4a6534101a83da8d95d2333af4b5d45b45f56f9aa3a')
|
||||
provides=("python-pychromecast=$pkgver")
|
||||
conflicts=('python-pychromecast')
|
||||
|
||||
build() {
|
||||
cd "$_name-$pkgver"
|
||||
patch -p0 -i ../is_alive.patch
|
||||
python setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "$_name-$pkgver"
|
||||
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
|
||||
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
10
python-pychromecast6/is_alive.patch
Normal file
10
python-pychromecast6/is_alive.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- pychromecast/__init__.py 2020-06-28 00:58:09.000000000 -0700
|
||||
+++ - 2020-12-07 09:21:51.082051341 -0800
|
||||
@@ -443,7 +443,7 @@
|
||||
operation in seconds (or fractions thereof). Or None
|
||||
to block forever.
|
||||
"""
|
||||
- if not self.socket_client.isAlive():
|
||||
+ if not self.socket_client.is_alive():
|
||||
self.socket_client.start()
|
||||
self.status_event.wait(timeout=timeout)
|
Loading…
Reference in New Issue
Block a user