git subrepo pull python-casttube
subrepo: subdir: "python-casttube" merged: "87eea3c" upstream: origin: "https://aur.archlinux.org/python-casttube" branch: "master" commit: "87eea3c" git-subrepo: version: "0.4.3" origin: "???" commit: "???"
This commit is contained in:
parent
54cb48a275
commit
6ac32fe329
@ -1,17 +1,14 @@
|
||||
pkgbase = python-casttube
|
||||
pkgdesc = YouTube chromecast api
|
||||
pkgdesc = YouTube Chromecast API
|
||||
pkgver = 0.2.1
|
||||
pkgrel = 2
|
||||
pkgrel = 3
|
||||
url = http://github.com/ur1katz/casttube
|
||||
arch = any
|
||||
license = MIT
|
||||
makedepends = python-setuptools
|
||||
depends = python
|
||||
depends = python-requests
|
||||
source = https://github.com/ur1katz/casttube/archive/0.2.1.tar.gz
|
||||
source = license.patch
|
||||
sha256sums = 351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33
|
||||
sha256sums = cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556
|
||||
source = https://pypi.org/packages/source/c/casttube/casttube-0.2.1.tar.gz
|
||||
sha256sums = 54d2af8c7949aa9c5db87fb11ef0a478a5d3e7ac6d2d2ac8dd1711e3a516fc82
|
||||
|
||||
pkgname = python-casttube
|
||||
|
||||
|
7
python-casttube/.gitignore
vendored
Normal file
7
python-casttube/.gitignore
vendored
Normal file
@ -0,0 +1,7 @@
|
||||
# Ignore everything
|
||||
*
|
||||
|
||||
# But not these files...
|
||||
!.gitignore
|
||||
!PKGBUILD
|
||||
!.SRCINFO
|
@ -6,7 +6,7 @@
|
||||
[subrepo]
|
||||
remote = https://aur.archlinux.org/python-casttube
|
||||
branch = master
|
||||
commit = c04a50ce8997e235540bd048ef7b573ab7c9cedd
|
||||
parent = cbafd65c02043dbff1f2d73a4caaa1fcd181d740
|
||||
commit = 87eea3cdedf4a89274c880b77eecec6030ed42a3
|
||||
parent = 54cb48a275b71887b80070177976dc705f422a11
|
||||
method = merge
|
||||
cmdver = 0.4.3
|
||||
|
@ -1,32 +1,28 @@
|
||||
# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
|
||||
|
||||
_name=casttube
|
||||
pkgname="python-$_name"
|
||||
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
|
||||
# Contributor: Sibren Vasse <arch@sibrenvasse.nl>
|
||||
pkgname=python-casttube
|
||||
_name=${pkgname#python-}
|
||||
pkgver=0.2.1
|
||||
pkgrel=2
|
||||
pkgdesc='YouTube chromecast api'
|
||||
url='http://github.com/ur1katz/casttube'
|
||||
depends=('python' 'python-requests')
|
||||
makedepends=('python-setuptools')
|
||||
license=('MIT')
|
||||
pkgrel=3
|
||||
pkgdesc="YouTube Chromecast API"
|
||||
arch=('any')
|
||||
source=("https://github.com/ur1katz/casttube/archive/${pkgver}.tar.gz"
|
||||
license.patch)
|
||||
sha256sums=('351819818a10a107641675cab71c4154afb490762410b3138c18ef410cbf5c33'
|
||||
'cfd4952db463d970ae6d1121f23f11ccb56322fdc413effbb55a45e8b05c9556')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
patch --forward --strip=1 --input="${srcdir}/license.patch"
|
||||
}
|
||||
url="http://github.com/ur1katz/casttube"
|
||||
license=('MIT')
|
||||
depends=('python-requests')
|
||||
makedepends=('python-setuptools')
|
||||
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
|
||||
sha256sums=('54d2af8c7949aa9c5db87fb11ef0a478a5d3e7ac6d2d2ac8dd1711e3a516fc82')
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
cd "$_name-$pkgver"
|
||||
python setup.py build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${_name}-${pkgver}"
|
||||
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
|
||||
cd "$_name-$pkgver"
|
||||
export PYTHONHASHSEED=0
|
||||
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
|
||||
|
||||
install -d "$pkgdir/usr/share/licenses/$pkgname"
|
||||
mv "$pkgdir/usr/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
|
||||
}
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff --git a/setup.py b/setup.py
|
||||
index feb39f2..14fb206 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -12,7 +12,6 @@ setup(name='casttube',
|
||||
author='Uri Katz',
|
||||
author_email='4urikatz@gmail.com',
|
||||
license='MIT',
|
||||
- data_files = [("", ["LICENSE"])],
|
||||
packages=['casttube'],
|
||||
zip_safe=False,
|
||||
keywords = ['youtube', 'chromecast', 'youtube-api'],
|
Loading…
Reference in New Issue
Block a user