git subrepo pull (merge) spnavcfg

subrepo:
  subdir:   "spnavcfg"
  merged:   "cfcd299"
upstream:
  origin:   "https://aur.archlinux.org/spnavcfg"
  branch:   "master"
  commit:   "ee823f9"
git-subrepo:
  version:  "0.4.3"
  origin:   "???"
  commit:   "???"
This commit is contained in:
Gabriel Ebner 2021-01-07 15:10:48 +01:00
parent 7bbbbe01f2
commit 5624b373ec
4 changed files with 28 additions and 13 deletions

View File

@ -1,8 +1,8 @@
pkgbase = spnavcfg pkgbase = spnavcfg
pkgdesc = The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc). pkgdesc = The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc).
pkgver = 0.3 pkgver = 0.3.1
pkgrel = 2 pkgrel = 3
url = http://spacenav.sourceforge.net/ url = https://github.com/FreeSpacenav/spnavcfg
arch = i686 arch = i686
arch = x86_64 arch = x86_64
license = GPL license = GPL
@ -10,8 +10,10 @@ pkgbase = spnavcfg
makedepends = make makedepends = make
depends = gtk2 depends = gtk2
provides = spnavcfg provides = spnavcfg
source = http://downloads.sourceforge.net/spacenav/spnavcfg-0.3.tar.gz source = https://github.com/FreeSpacenav/spnavcfg/releases/download/v0.3.1/spnavcfg-0.3.1.tar.gz
md5sums = ac4ac49b07c4a4dbfa6ba1cd0d357273 source = Makefile.in.diff
md5sums = bf5bda8e4fd3fa3e45fe47cd26394fae
md5sums = b85402ad686e3ef10446c192166c3a0a
pkgname = spnavcfg pkgname = spnavcfg

View File

@ -6,7 +6,7 @@
[subrepo] [subrepo]
remote = https://aur.archlinux.org/spnavcfg remote = https://aur.archlinux.org/spnavcfg
branch = master branch = master
commit = e8d31fafbd31df23c4408f7865c47d65816fd233 commit = ee823f9e6b665217bc9ae8801b834744cd215d49
parent = d5ba18ab24ef9c499c31289f363404099492740c parent = d5ba18ab24ef9c499c31289f363404099492740c
method = merge method = merge
cmdver = 0.4.1 cmdver = 0.4.3

11
spnavcfg/Makefile.in.diff Normal file
View File

@ -0,0 +1,11 @@
--- Makefile.in 2021-01-06 23:26:24.592552843 +0100
+++ Makefile.in 2021-01-06 23:26:30.342582189 +0100
@@ -39,7 +39,7 @@
destdir=$(DESTDIR)$(PREFIX)/share/icons/hicolor/$${i}x$${i}/apps; \
mkdir -p $$destdir; \
rm -f $$destdir/spnavcfg-$${i}x$${i}.png; \
- ln -s $(DESTDIR)$(PREFIX)/share/pixmaps/spnavcfg-$${i}x$${i}.png $$destdir/spnavcfg-$${i}x$${i}.png; \
+ ln -rs $(DESTDIR)$(PREFIX)/share/pixmaps/spnavcfg-$${i}x$${i}.png $$destdir/spnavcfg-$${i}x$${i}.png; \
done
mkdir -p $(DESTDIR)$(PREFIX)/share/applications
cp -a icons/spnavcfg.desktop $(DESTDIR)$(PREFIX)/share/applications/

View File

@ -1,22 +1,24 @@
# Maintainer: Jan Hambrecht <jaham at gmx dot net> # Maintainer: Jan Hambrecht <jaham at gmx dot net>
pkgname=spnavcfg pkgname=spnavcfg
pkgver=0.3 pkgver=0.3.1
pkgrel=2 pkgrel=3
pkgdesc="The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc)." pkgdesc="The spacenav project provides a free, compatible alternative, to the proprietary 3Dconnexion device driver and SDK, for their 3D input devices (called 'space navigator', 'space pilot', 'space traveller', etc)."
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
url="http://spacenav.sourceforge.net/" url="https://github.com/FreeSpacenav/spnavcfg"
license=('GPL') license=('GPL')
depends=(gtk2) depends=(gtk2)
makedepends=('gcc' 'make') makedepends=('gcc' 'make')
provides=('spnavcfg') provides=('spnavcfg')
options=() options=()
install= install=
source=(http://downloads.sourceforge.net/spacenav/$pkgname-$pkgver.tar.gz) source=(https://github.com/FreeSpacenav/spnavcfg/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz
md5sums=('ac4ac49b07c4a4dbfa6ba1cd0d357273') Makefile.in.diff)
md5sums=('bf5bda8e4fd3fa3e45fe47cd26394fae'
'b85402ad686e3ef10446c192166c3a0a')
build() { build() {
cd ${pkgname}-${pkgver} cd ${pkgname}-${pkgver}
patch -p0 < $startdir/Makefile.in.diff
./configure --prefix=/usr ./configure --prefix=/usr
make || return 1 make || return 1
} }