git subrepo clone --branch=master https://aur.archlinux.org/python-gbinder.git
subrepo: subdir: "python-gbinder" merged: "e49c0fc" upstream: origin: "https://aur.archlinux.org/python-gbinder.git" branch: "master" commit: "e49c0fc" git-subrepo: version: "0.4.3" origin: "???" commit: "???"
This commit is contained in:
parent
04c8fc9056
commit
127c541985
20
python-gbinder/.SRCINFO
Normal file
20
python-gbinder/.SRCINFO
Normal file
@ -0,0 +1,20 @@
|
||||
pkgbase = python-gbinder
|
||||
pkgdesc = Python bindings for libgbinder
|
||||
pkgver = 1.0.0
|
||||
pkgrel = 3
|
||||
url = https://github.com/erfanoabdi/gbinder-python
|
||||
arch = x86_64
|
||||
arch = i686
|
||||
arch = armv7h
|
||||
arch = aarch64
|
||||
license = GPL
|
||||
makedepends = git
|
||||
makedepends = python-setuptools
|
||||
makedepends = cython
|
||||
depends = libgbinder
|
||||
source = python-gbinder::git+https://github.com/erfanoabdi/gbinder-python.git#commit=2e1e05c0a0240d6c06e9bbe9b22dcc35c2e0211c
|
||||
source = 79d40e9e564772973f7f085ed5c48e3fc625e0f5.patch
|
||||
sha512sums = SKIP
|
||||
sha512sums = 9b07a8fec380c7b5cb9de296a8519f3fd71bd59266d6dc888e2cf7a65c57d9d05fd2a2261405c97eb1e79518264971124e977c249037a8e4a60a7d96dcb50897
|
||||
|
||||
pkgname = python-gbinder
|
12
python-gbinder/.gitrepo
Normal file
12
python-gbinder/.gitrepo
Normal file
@ -0,0 +1,12 @@
|
||||
; DO NOT EDIT (unless you know what you are doing)
|
||||
;
|
||||
; This subdirectory is a git "subrepo", and this file is maintained by the
|
||||
; git-subrepo command. See https://github.com/git-commands/git-subrepo#readme
|
||||
;
|
||||
[subrepo]
|
||||
remote = https://aur.archlinux.org/python-gbinder.git
|
||||
branch = master
|
||||
commit = e49c0fcaaf410c010feefeaa996e5f7622be7935
|
||||
parent = 04c8fc90560901dce8ef468b75fe596150875ec1
|
||||
method = merge
|
||||
cmdver = 0.4.3
|
@ -0,0 +1,22 @@
|
||||
From 79d40e9e564772973f7f085ed5c48e3fc625e0f5 Mon Sep 17 00:00:00 2001
|
||||
From: Erfan Abdi <erfangplus@gmail.com>
|
||||
Date: Mon, 6 Sep 2021 13:57:22 +0430
|
||||
Subject: [PATCH] setup: Drop None from keywords
|
||||
|
||||
---
|
||||
setup.py | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/setup.py b/setup.py
|
||||
index cf3a42e..ed2b1ed 100644
|
||||
--- a/setup.py
|
||||
+++ b/setup.py
|
||||
@@ -19,6 +19,8 @@ def pkgconfig(package, kw):
|
||||
|
||||
extension_kwargs = { 'sources': ["gbinder" + file_ext] }
|
||||
extension_kwargs = pkgconfig('libgbinder', extension_kwargs)
|
||||
+if None in extension_kwargs:
|
||||
+ del extension_kwargs[None]
|
||||
extensions = [Extension('gbinder', **extension_kwargs)]
|
||||
|
||||
if USE_CYTHON:
|
36
python-gbinder/PKGBUILD
Normal file
36
python-gbinder/PKGBUILD
Normal file
@ -0,0 +1,36 @@
|
||||
# Maintainer: Danct12 <danct12@disroot.org>
|
||||
|
||||
pkgname=python-gbinder
|
||||
pkgver=1.0.0
|
||||
pkgrel=3
|
||||
pkgdesc="Python bindings for libgbinder"
|
||||
arch=('x86_64' 'i686' 'armv7h' 'aarch64')
|
||||
url="https://github.com/erfanoabdi/gbinder-python"
|
||||
license=('GPL')
|
||||
depends=('libgbinder')
|
||||
makedepends=('git' 'python-setuptools' 'cython')
|
||||
_commit="2e1e05c0a0240d6c06e9bbe9b22dcc35c2e0211c"
|
||||
source=(${pkgname}::git+https://github.com/erfanoabdi/gbinder-python.git#commit=${_commit}
|
||||
'79d40e9e564772973f7f085ed5c48e3fc625e0f5.patch')
|
||||
sha512sums=('SKIP'
|
||||
'9b07a8fec380c7b5cb9de296a8519f3fd71bd59266d6dc888e2cf7a65c57d9d05fd2a2261405c97eb1e79518264971124e977c249037a8e4a60a7d96dcb50897')
|
||||
|
||||
pkgver() {
|
||||
cd ${pkgname}
|
||||
git describe --tags | sed 's/^v//;s/-/+/g'
|
||||
}
|
||||
|
||||
prepare() {
|
||||
cd ${pkgname}
|
||||
patch -p1 -N < ../79d40e9e564772973f7f085ed5c48e3fc625e0f5.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}
|
||||
python3 setup.py build --cython
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}
|
||||
python3 setup.py install --prefix=/usr --root="$pkgdir"
|
||||
}
|
Loading…
Reference in New Issue
Block a user